CodeNewbie Community

Shrikant Dhayje
Shrikant Dhayje

Posted on • Originally published at blog.shriekdj.tk on

Let's Install Heroku CLI On Termux an android app.

Today I Tried To Install Heroku CLI On Termux But It Does Not Worked i Tried To Install Nodejs First For Building The Heroku CLI From Built but It Does Not Work At All.

apt install heroku
does not work said heroku not available
snapd package also unable to install on termux.
and also when tried same error
npm install heroku
it shows error sudo permissions need

At Last This Last Commands Worked

apt-get install proot-distro

proot-distro install ubuntu

proot-distro login ubuntu

apt-get install curl

curl https://cli-assets.heroku.com/install-ubuntu.sh | sh
Enter fullscreen mode Exit fullscreen mode

My Actual Issue Was My Mobile Is Not Rooted and Niether I Wanted to Root It So I Just Installed Virtual Machine of Ubuntu Instead.

You Can Run Ubuntu and Also Other Distro Like ArchLinux, Fedora, OpenSuse, etc.,

I Know It Is Not A Good Practice to Install these Things On Android Mobile But termux also works on Android Television.

You Can Use Your Android TV As Backup Linux Machine think About It.

IMP: package name is proot-distro the word distro is mandatory

Discussion (0)